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Nội dung của trang này thuộc bản quyền của © Bá tước Monte Cristo - Final Fantasy và www.vietphotoshop.com. Những bài viết 

trong này có thể được in ra để dùng với mục đích cá nhân và phi thương mại. Nếu bạn muốn phát hành lại trong trang web của bạn làm 

ơn liên lạc với tôi hoặc ít nhất phải trích dẫn lại nguồn là: Bá tước Monte Cristo - Final Fantasy và www.vietphotoshop.com 

 

  

Để có những hình ảnh hiệu quả trên trang Web, hình ảnh của bạn phải có được sự cân bằng hài hoà 

giữa kích thước file ảnh và chất lượng ảnh. Sử dụng Adobe Photoshop và Adobe Image Ready, bạn có 

thể tối ưu hoá hình ảnh của bạn để những hình ảnh này có thể được tải xuống nhiều lần từ máy chủ 

mà không bị mất đi những chi tiết quan trọng, độ trông suốt, các thành phần chuyển dịch chẳng hạn 

như bản đồ ảnh. (image map) 

 

Trong bài học này, bạn sẽ học cách làm sau: 

• Tối ưu hoá các tập tin dạng JPEG và GIF, điều chỉnh các xác lập tối ưu hoá để đạt được sự 

cân bằng giữa kích cở ảnh và chất lượng ảnh. 

• Xác định độ trong suốt cho một ảnh. 

• Xử lý hàng loạt các tập tin nhằm tự động hoá quá trình tối ưu hoá. 

Bài học này cần 1 tiếng 30 phút để hoàn tất. Bài học này được soạn dành cho Adobe Photoshop và 

Adobe ImageReady. 

 

Chú ý: Những người sử dụng Window 2000 cần mở những tập tin bài học trước khi sử dụng chúng. 

Để biết thêm thông tin, xem phần “Copying the Classroom in a Book files” ở trang 3. 
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Sử dụng Photoshop và ImageReady để tối ưu ho hình ảnh 

Tối ưu hoá là quá trình chọn dạng, độ phân giải, và các xác lập về chất lượng ảnh để một ảnh có hiệu 

quả, bắt mắt 

và tiện ích cho các trang duyệt web. Nói một cách đơn giản, đó chính là sự hài hoà giữa kích cở ảnh và 

chất lượng ảnh. Không có một tập hợp các xác lập đơn lẻ nào có thể tối ưu hoá mức hữu hiệu của mỗi 

loại ảnh, tối ưu hoá đòi hỏi nhận xét và mắt thẩm mỹ của con người. 

 

Các tuỳ chọn nén thay đổi tuỳ theo dạng tập tin khi lưu. Bạn nên làm quen với những loại dạng tổng 

quát. 

• Dạng JPEG được thiết kế để giữ lại độ màu rộng và độ sáng rõ của những ảnh có tông màu 

liên tục (chẳng hạn như những ảnh ở chế độ tô màu gradient). Dạng này có thể tiêu biểu cho 

những ảnh 

sử dụng hàng triệu màu. 

• Dạng GIF hiệu quả đối với những ảnh nén màu đặc và những ảnh có những vùng màu lập lại 

(chẳng hạn như nghệ thuật đường thẳng, các biểu tượng và những hình minh hoạ có chữ). 

Dạng này sử dụng một bảng gồm 256 màu để thể hiện hình ảnh và hỗ trợ cho độ trong suốt 

của nền. 

• Dạng PNG hiệu quả đối với những ảnh nén màu đặc và giữ được chi tiết sắc nét. Dạng PNG-8 

sử dụng bảng 256 màu để thể hiện 1 ảnh. Dạng PNG-24 hỗ trợ màu 24 bit (hàng triệu màu), 

tuy nhiên nhiều ứng dụng trình duyệt trước đây không hỗ trợ các tập tin dạng PNG. 

• Dạng WBNG là dạng chuẩn cho việc tối ưu hoá các hình ảnh đối với các thiết bị di động chẳng 

hạn như điện thoại di động. Dạng WBMP hỗ trợ màu 1 bit, có nghĩa là những ảnh dạng WBMP 

chỉ chứa những điểm ảnh màu đen và màu trắng. 

Chú ý: Để có thông tin về việc sử dụng các dạng PNG và WBNG, xem phần Trợ Giúp của Photoshop.  

Adobe Photoshop và Adobe ImageReady sẽ cho bạn một phạm vi điều khiển hiệu quả đối với việc nén 

kích thước tập tin của một ảnh trong khi tối ưu hoá chất lượng ảnh thể hiện trên màn hình. Bạn có thể 

áp dụng một tập hợp các thiết lập tối ưu cho một tập hợp ảnh, một ảnh rời, một lớp (layer) hay 1 tấm 

phim chụp  (slice).  

Trong bài học này bạn sẽ tối ưu hoá và lưu các hình ảnh ở dạng JPEG v à GIF. Trong các bài tập tiếp 

theo sau, bạn sẽ làm việc với một loạt ảnh được thiết kế để sử dụng trên trang web cho các tổ chức du 

lịch giả tưởng. 

 

Photoshop (qua hộp thoại Save for web) và ImageReady (qua bảng Optimize) có nhiều khả năng giống 

nhau về việc tối ưu hoá hình ảnh. Thí dụ, bạn có thể sử dụng trình ứng dụng để chọn một mảng rộng 
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các dạng tập tin và các xác lập cho phù hợp với các mục tiêu đối với dự án của bạn. Bạn cũng có thể 

dùng một trong hai chương trình để so sánh những ảnh đặt kế bên nhau có mức độ tối ưu hoá khác 

nhau của cùng một tập tin. Sử dụng những đặc điểm tối ưu hoá và bảng màu trong Adobe Photoshop 

và ImageReady, bạn có thể làm tối đa tính trọn vẹn của màu sắc trong khi làm cho kích thước tập tin 

ảnh giảm tối thiểu. 

 

Bắt đầu 

Bạn sẽ làm phần đầu tiên của bài học này trong Photoshop nhưng đồng thời cũng có thể làm trong 

chương trình ImageReady. Khi bắt đầu bạn sẽ phục hồi lại những thiết lập ứng dụng mặc định cho 

Photoshop để những mô tả trong phần chỉ dẫn phù hợp với những thiết lập trong vùng làm việc 

của Photoshop. 

 

Bài học này xoay quanh đồ hoạ trang chủ cho tổ chức du lịch giả tưởng. 

 

1. Khởi động Photoshop trong khi nhấn phím Ctrl+Alt+Shift (window) hoặc Command +Option+Shift 

(Mac OS) để phục hồi những ưu tiên mặc định. (Xem “Phục hồi những ưu tiên mặc định” ở trang 4). 

 

Khi những dòng thông báo xuất hiện, chọn Yes để xác định rằng bạn muốn thiết lập lại những ưu tiên, 

chọn No để hoãn lại việc thiết lập màn hình màu của bạn,và chọn Close để đóng lại màn hình 

Welcome. 

 

2. Bấm nút File Browser trên thanh tuỳ chọn công cụ để mở nó ra. 

 

3. Trong bảng các thư mục của File browser, xác định và chọn thư mục Lesson 16 trong thư mục 

Lesson. 

Những ảnh nhỏ của 3 tập tin bắt đầu và kết thúc khác nhau xuất hiện trong bảng chứa ảnh nhỏ, nhiều 

ảnh trong số những ảnh này có vẻ hoàn toàn giống nhau. 

 

4. Chọn-nhưng không mở ra ảnh nhỏ có tên 16Start1.psd để ảnh này được sáng lên và metadata xuất 

hiện trong bảng Metadata. 

www.vietphotoshop.com  - Dịch bởi Nguyễn Tấn Sĩ 3



Chương 16: Tối ưu hoá hình ảnh trên trang web                                                                         Photoshop CS 

 

5. Chọn ảnh nhỏ có tên 16End1.jpg. Chú ý là kích thước tập tin được liệt kê trong phần metadata thì 

nhỏ hơn nhưng ảnh này trong giống như ảnh 16Start1.psd. 

 

6. Lần lượt chọn và xem trước những tập tin Start và End khác trong thư mục Lesson 16. 

 

7. Nhấp đúp tập tin ảnh 16Start1.psd để mở nó trong Photoshop. Đóng File Browser lại bằng cách 

hoặc bấm vào nút có biểu tượng File Browser trên thanh tuỳ chọn công cụ 2 lần (một lần để đưa nó 

về phía trước và một lần để đóng nó lại) hoặc bấm nút Close trong cửa sổ của File Browser. 

 

Tối ưu hoá 1 ảnh JPEG (Photoshop) 
Trong bài học này, bạn sẽ tối ưu hoá những tập tin vừa ở dạng JPEG vừa ở dạng GIF. Mục tiêu của 

bạn là thiết lập những lựa chọn tối ưu để những tập tin ảnh của bạn nhỏ, hiệu quả nhưng vẫn đẹp mắt. 

 

Hiện giờ, kích thước của ảnh 16Start1.psd lớn hơn mức lý tưởng để sử dụng trên 1 trang web. Bạn sẽ 

so sánh những dạng tập tin nén khác nhau để thấy ảnh nào có độ 

nén cao nhất mà không mất đi quá nhiều chất lượng ảnh. 
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Sử dụng hộp thoại Save For Web 

Hộp thoại Save For Web trong Photoshop cho bạn thấy những tấm ảnh đặt bên cạnh nhau nhưng khác 

nhau do việc sử dụng những thiết lập tối ưu hoá khác nhau. Bạn có thể so sánh các phiên bản khi làm 

việc, chỉnh các thiết lập tối ưu và tìm xem những khác biệt cho đến khi bạn có được sự kết hợp khả dĩ 

giữa kích thước và chất lượng của ảnh. 

 

1. Với tập tin của ảnh 16Start1.psd đang mở và kích hoạt trong Photoshop, chọn File >Save for Web. 

Chú ý : Nếu thẻ 4-up chưa được chọn trong cửa sổ ảnh, hãy chọn nó. 

  

Photoshop tự động đưa ra 3 thiết lập tối ưu ngoài ảnh gốc ra. Chú ý thông tin được trình bày dưới mỗi 

ảnh gồm có kích thước tập tin và thời gian (tính bằng giây) cần thiết để tải ảnh đó xuống. Bảng đầu tiên 

cho thấy ảnh gốc. Các bảng thứ 2, 3, 4 thể hiện sự kết hợp khác nhau của việc thiết lập tối ưu đối với 

ảnh này bao gồm dạng tập tin (như GIF hoặc JPEG) và giải thuật giảm màu (như Selective, Perceptual 

hay Web)  

 

2. Ở góc dưới trái của hộp thoại Save For Web, chọn 300% từ menu pop-up Zoom Level để bạn có thể 

nhìn thấy những chi tiết của ảnh. 

So sánh những ảnh với các thiết lập tối ưu khác nhau. 

 

3. Bấm vào 1 trong 4 tấm ảnh để con trỏ biến thành biểu tượng hình bàn tay và kéo ảnh để bạn có thể 

thấy những khác biệt giữa những ảnh đã được tối ưu hoá và ảnh gốc. 

 

4. Nhìn cẩn thận các vùng sau đây: văn bản ở góc dưới phải của ảnh, vùng trên nắp hộp thư tương 

phản với nền trời màu xanh, bóng của cánh cửa rỉ sét của 

hộp thư lớn,vùng nổi lên của hộp thư rỉ sét và những chi tiết khác của ảnh.  
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So sánh các dạng GIF, JPEG và PNG đã được tối ưu hoá 

Bạn có thể tạo tuỳ biến bất kỳ ảnh nào trong 3 ảnh được tối ưu hoá trong hộp thoại Save For Web. Để 

làm điều này, bạn chọn xem trước 1 trong những ảnh đã được tối ưu hoá rồi chọn các thiết lập cho nó 

phía bên phải của hộp thoại. Qua việc thử nghiệm với nhiều thiết lập khác nhau, bạn sẽ có được ý 

tưởng hay thiết lập nào phù hợp nhất với mục đích của bạn. 

 

Chú ý : Khi thực hiện các thao tác trong bài học này, hãy sử dụng công cụ định tỉ lệ thường xuyên để 

bạn có được cái nhìn toàn cảnh của bức ảnh và thấy được những chi tiết nhỏ cho bạn thấy những 

khiếm khuyết mà bạn không nhìn thấy ở độ phóng đại nhỏ hơn. Mỗi thao tác đừng chờ những chỉ dẫn 

yêu cầu bạn phóng to hay thu nhỏ. 

 

1. Chọn ảnh xem trước đã được tối ưu hoá ở góc trên phải của hộp thoại Save For Web. 

 

2. Trong menu pop-up Preset bên phải hộp thoại, chọn GIF 128 Dithered (nếu ảnh này chưa được 

chọn) 

Thông tin được trình bày ngay bên dưới những thay đổi của ảnh xem trước. (xem hình) 
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Hãy Chú ý nhóm điểm ảnh màu xậm quanh hộp thư bị sét bao phủ và trong phần nền vuông xanh lá 

cây phía sau con số 4 trong biểu tượng. 

Bạn sẽ dùng 2 phiên bản ở phía dưới của ảnh để so sánh việc tối ưu hoá của tập tin GIF 128 Dithered 

với việc tối ưu hoá của dạng JPEG và PNG. 

3. Bấm vào phiên bản ảnh ở góc dưới trái để chọn nó và chọn các tuỳ chọn JPEG sau đây, mỗi thời 

điểm chọn 1 lần trên menu pop-up Preset:  

• JPEG Low. Chú ý là các chi tiết ảnh và văn bản nhăn nhúm không chấp nhận được. 

• JPEG High. Chất lượng ảnh được cải thiện nhưng kích cở ảnh còn hơn gấp 3 lần. (Xem hình) 

 

• JPEG Medium. Với thiết lập này, chất lượng ảnh có thể chấp nhận được và kích thước ảnh 

thấp hơn phiên bản với tuỳ chọn là JPEG High hoặc GIF.  

Chú ý: Bạn có thể chọn mức độ chất lượng trung bình khác cho tập tin JPEG bằng cách gõ vào hoặc 

kéo con trỏ về bên phải của hộp thoại Save For Web.  

 

Vì bạn đã thử các thiết lập khác nhau của dạng GIF và JPEG, bạn sẽ dùng ảnh xem trước thứ tư để 

thử một dạng khác.  

 

www.vietphotoshop.com  - Dịch bởi Nguyễn Tấn Sĩ 7



Chương 16: Tối ưu hoá hình ảnh trên trang web                                                                         Photoshop CS 

4. Chọn ảnh nằm ở góc dưới phải rồi sử dụng menu Preset để chọn dạng PNG-8 128 dithered.  

Dù các kết quả này cho kích cở tập tin nhỏ hơn ảnh gốc, chất lượng ảnh không đẹp bằng ảnh JPEG 

Medium, cũng có kích cở tập tin nhỏ hơn. Hơn nữa, nhiều trình duyệt trước đây không đọc được dạng 

PNG. Để làm cho ảnh này tương thích với các trình duyệt trước đây, bạn sẽ lưu tập tin này cho trang 

Web bằng cách sử dụng 

độ tối ưu hoá của dạng JPEG Medium. 

 

5. Chọn dạng JPEG Medium của ảnh đã được tối ưu (ở góc dưới trái của hộp thoại) và chọn hộp kiểm 

Progressive.  

Chú ý: Khi mục Progressive được chọn, bất kỳ khi nào việc tải hình ảnh xuống bằng nhiều con đường 

xảy ra, mỗi con đường gia tăng chất lượng hình ảnh. 

  

 
 

6. Bấm Save. Trong hộp thoại Save optimized as, dùng tên mặc định 16Start1.jpeg và lưu tập tin này 

trong cùng thư mục với tập tin gốc của Photoshop. 

7. Chọn File > Close để đóng tập tin 16Start1.psd và đừng lưu những thay đổi của bạn. 

 

Tối ưu hoá một ảnh dạng GIF 

Bây giờ bạn sẽ tối ưu hoá một ảnh được cách điệu hoá thành những màu nhạt, có nghĩa là những 

vùng mà các điểm ảnh kế bên nhau có giá trị màu RGB tương tự nhau. Bạn sẽ tối ưu hoá ảnh này ở 

dạng GIF và so sánh các kết quả của bảng màu khác và các thiết lập hoà sắc. Dù bạn có thể làm cả 

phần này trong Photoshop, bạn sẽ dùng ImageReady.  

 

Photoshop và ImageReady có nhiều đặc điểm chung nhưng có một số thao tác nào đó bạn có thể làm 

trong Photoshop nhưng không thể làm được trong ImageReady và ngược lại. Một số thao tác được 

thực hiện phù hợp hơn trong một trình ứng dụng này hay trình ứng dụng khác. 

 

Nếu bạn có một tập tin đang mở, khi bạn nhảy từ trình ứng dụng này sang trình ứng dụng khác, tập tin 

sẽ nhảy sang trình ứng dụng bạn đang mở. Nếu bạn có nhiều 

tập tin đang mở, chỉ có tập tin kích hoạt mới được mở trong trình ứng dụng mà bạn vừa nhảy sang. 
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Nếu không có tập tin nào được mở, bạn có thể nhảy tới hoặc lui từ trình ứng dụng này sang trình ứng 

dụng khác. Trong mọi trường hợp, xử lý chỉ là một cái bấm chuột. 

 

Sử dụng không gian làm việc của ImageReady được xác định trước 

Trước khi bắt đầu làm việc trên một tập tin mới, bạn sẽ nhảy từ Photoshop sang ImageReady. Bạn sẽ 

sắp xếp lại vùng làm việc bằng cách chọn một trong những không gian làm việc được xác định trước 

luôn luôn sẵn có trên menu con vùng làm việc của ImageReady. 

 

1. Trong Photoshop bạn bấm nút chuyển sang ImageReady ở cuối hộp công cụ để chuyển từ 

Photoshop sang ImageReady.  

 
 

Chú ý: Nếu bạn không có đủ bộ nhớ (ram) để chạy 2 trình ứng dụng này cùng một lúc, thoát khỏi 

Photoshop và bắt đầu với ImageReady. 

 

2. Trong ImageReady, chọn Window > Workspace > Optimization Palette Locations. 

Chỉ có bộ Palette chủ yếu cần thiết cho thao tác tối ưu hoá được mở ra trong vùng làm việc : Nhóm 

Palette tối ưu hoá và nhóm Palette Color Table, cùng với hộp công cụ và thanh tuỳ chọn công cụ. Nếu 

bạn cần một Palette khác tại một thời điểm nào đó, bạn có thể mở lại nó bằng cách chọn nó trên menu 

Window.  

  

Chọn những thiết lập tối ưu trong ImageReady  

Trước đây trong bài học này, bạn dùng các thiết lập tối ưu của Photoshop được tích hợp trong hộp 

thoại Save For Web. Trong ImageReady, các tuỳ chọn tương tự xuất hiện trong Palette Optimize. 

 

1. Trong ImageReady, chọn File > Open và mở tập tin 16Start1.psd trong thư mục Lesson16 trong thư 

mục Lesson. 

Ảnh này được được tạo ra trong Adobe Illustrator và được mành hoá thành dạng Photoshop. Ảnh này 

có chứa nhiều vùng màu đặc. 

 

2. Bấm tab 2-up trong cửa sổ ảnh. 
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Phiên bản của ảnh được tối ưu hoá được chọn bên tay phải của cửa sổ. 

 

3. Trong menu Preset pop-up trên Palette Optimize, chọn tập tin GIF 128 No Dither. 

 
 

4. Nếu cần, bấm mũi tên để mở rộng tuỳ chọn Color Table trên Palette Optimize rồi chọn Perceptual 

trên Menu pop-up Reduction.  
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Chọn một giải thuật giảm màu 

Một trong những cách giảm kích thước tập tin là giảm số màu trong ảnh. Photoshop có thể tính toán 

những màu cần thiết nhất cho bạn dựa trên nhiều giải thuật sẵn có. Bạn xác định giải thuật nào được 

sử dụng bằng cách chọn từ menu Color Reduction Algorithm giải thuật nào bao gồm những tuỳ chọn 

sau đây: 

 

Cảm nhận (Perceptual): Tạo một bảng màu thông thường bằng cách đưa ra những màu ưu tiên mà 

mắt nguời có độ cảm nhận lớn hơn. 

Chọn lọc (Selective): Tạo một bảng màu tương tự với bảng màu Perceptual nhưng ưu tiên những 

vùng màu rộng và giữ lại những màu của trang Web. Bảng màu này 

thường tạo ra những ảnh có độ hoàn chỉnh màu lớn nhất. Phần chọn lọc (Selective) là tuỳ chọn mặc 

định.  

Thích nghi (Adaptive): Tạo bảng màu thông thường bằng cách lấy mẩu những màu từ quang phổ 

thường xuất hiện nhất trong ảnh. Thí dụ, một ảnh chỉ có màu xanh lá cây và xanh biển tạo ra một bảng 

màu chủ yếu chỉ có màu xanh lá cây và xanh biển. Hầu hết các ảnh đều tập trung các màu vào những 

vùng đặc biệt của quang phổ. 

 

Web sử dụng bảng màu chuẩn gồm 256 màu thông thường đối với các bảng màu Window và Mac OS 

8-bit (256 màu). Hệ thống nấy đảm bảo được rằng không có sự hoà sắc nào được áp dụng cho các 

màu khi những hình ảnh được thể hiện sử dụng màu 8 bit. Bảng này còn được gọi là bảng Web an 

toàn. Nếu hình ảnh của bạn có ít màu hơn tất cả màu trong palette màu, những màu bất thường bị loại 

đi. 

 

Tự tạo (Custom): Giữ lại bảng màu hiện hành như một bảng màu cố định không cập nhật theo những 

thay đổi của hình ảnh. 

 

Window hoặc Mac OS Sử dụng bảng màu mặc định của hệ thống là 256 màu dựa trên mẫu thuần nhất 

của những màu RGB. Nếu ảnh của bạn có ít màu hơn số màu tổng cộng trong palette màu, màu bất 

thường cũng bị loại. 

 

Thanh trạng thái ở cuối cửa sổ ảnh thể hiện độ phóng đại và thông tin hữu ích khác về ảnh được tối ưu 

hoá và ảnh gốc.  

 
 

www.vietphotoshop.com  - Dịch bởi Nguyễn Tấn Sĩ 12



Chương 16: Tối ưu hoá hình ảnh trên trang web                                                                         Photoshop CS 

A. Kích thước tập tin và thời gian tải xuống hình ảnh đã được tối ưu hoá  

B. Kích thước của ảnh được tối ưu hoá và ảnh gốc. 

 

Bạn có thể tạo tuỳ biến cho loại thông tin xuất hiện ở đây. 

 

5. Ở thanh trạng thái, chọn Size/Download Time (56.6 Kbps Modem/ISDN) trong menu pop-up ở giữa 

rồi chọn Image Dimension từ menu pop-up bên phải.  

 
 

Tốc độ tải xuống 56.6 Kbps thông thường hơn tốc độ 28.8 Kbps. Kích thước này thể hiện kích cở của 

ảnh bằng những điểm ảnh. Đây là điều quan trọng cần biết để dự định làm thế nào cho 1 ảnh phù hợp 

với 1 mẫu của trang Web được thiết kế trước.  

 

Về bảng màu  

Palette Color Table thể hiện những màu mà việc sử dụng tuỳ chọn giảm màu dành cho tập tin được 

kích hoạt hiện hành. Số lượng màu dùng trong ảnh này được liệt kê ở dưới đáy của palette với nhiều 

nút khác nhau.Bạn có thể lấy lại kích cở của Palette hoặc dùng thanh cuộn để xem tất cả các màu.  

Bạn cũng có thể thay đổi cách các màu được sắp xếp trong Palette bằng cách bấm chuột vào mũi tên 

nhỏ để menu palette Color Table rồi chọn phương pháp phân loại : theo sắcmàu, theo độ sáng, hoặc 

theo mức độ phổ biến thường dùng. 

Những biểu tượng khác nằm ngay trên bảng màu mẫu cho biết mẫu màu hiện hành (nếu mẫu màu 

được chọn),cho dù một màu có bị khoá lại hay không, và cho dù một màu là màu bị giới hạn trên trang 

(web). Bạn sẽ học hỏi thêm nhiều về việc nhận diện và sử dụng những đặc điểm này khi tiến hành qua 

bài học này. 

Chú ý: Trong Photoshop, bảng Color Table nằm trong hộp thoại Save For Web.  
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Điều khiển độ hoà sắc và các màu giảm 

 Bạn có thể thấy rằng một số vùng nào đó của ảnh bị lốm đốm. Hiện tượng lốm đốm này là do độ hoà 

sắc. Kỹ thuật này được dùng để nhái những màu không có trong bảng màu. Thí dụ, màu xanh biển và 

màu vàng có thể hoà trộn theo một mẫu (gồm những mảnh màu nhỏ được ghép lại với nhau) để tạo ra 

một ảo giác có một màu xanh lá cây không nằm trong bảng màu.  

Khi tối ưu hoá hình ảnh, hãy Chú ý 2 loại hoà sắc có thể xảy ra: 

• Hoà sắc ứng dụng: xảy ra khi ImageReady hoặc Photoshop cố nhái những màu có trong ảnh 

gốc nhưng không có trong bảng màu tối ưu mà bạn xác định. Bạn có thể điều khiển độ hoà sắc 

ứng dụng bằng cách kéo con trượt Dither vào bảng Optimize.  

• Hoà sắc trình duyệt: có thể xảy ra bên cạnh hoà sắc ứng dụng. Hoà sắc trình duyệt xảy ra khi 

một trình duyệt web sử dụng những màu nhái 8 bit (256 màu) xuất hiện trong bảng màu của 

ảnh được tối ưu hoá nhưng không nằm trong bảng hệ thống do trình duyệt web sử dụng. Bạn 

có thể điều chỉnh độ hoà sắc trình duyệt bằng cách di chuyển những màu được chọn vào 

những màu web an toàn trong bảng Color Table.  

Trước khi bạn tối ưu hoá nhiều hơn, hãy phóng lớn ảnh tới 200% hoặc hơn và so sánh các vùng 

chuyển tiếp giữa những ảnh thật và nền màu đặc trong cả 2 phiên bản: Ảnh được tối ưu hoá và ảnh 

gốc được tối ưu hoá. Trong ảnh gốc, ảnh chụp cách điệu mờ dần vào nền. Trong ảnh được tối ưu hoá, 

sự dịch chuyển mang tính đột ngột và có các đường biên thô. Cũng vậy, hãy Chú ý những dãy màu 

mây hình cầu vòng ở vùng phía trên bên phải của ảnh thung lũng. 

 

Giảm palette màu 

Để nén kích cở tập tin được nhiều hơn, bạn có thể giảm lượng màu trong bảng Color Table. Phạm vi 

số màu bị giảm thường giữ lại chất lượng hình ảnh đẹp trong khi giảm dung lượng tập tin cần thiết để 

lưu trữ những màu thừa một cách ngoạn mục. 

 

Hiện giờ, 128 màu tạo ra tập tin 16Start1.psd được thể hiện trong tuỳ chọn Colors trong bảng Optimize 

bên dưới Color Table. Mục tiêu cuối cùng của bạn trong cả phần này là giảm con số màu xuống còn 32 

mà không làm hỏng đi bức ảnh. 

 

1. Đảm bảo rằng ảnh tối ưu hoá được chọn và cảm nhận (Perceptual) được chọn trong bảng 

Optimization. Chú ý kích cở tập tin hiện hành. 

 

2. Trên menu pop-up zoom ở đáy cửa sổ ảnh, chọn 200% hoặc lớn hơn hoặc sử dụng công cụ phóng 

đại để phóng lớn tấm ảnh của bạn. Đảm bảo rằng bạn phóng đại 

đủ lớn để bạn bắt đầu thấy hiện tượng điểm ảnh hoá của ảnh.  
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3. Dùng công cụ Hand Tool , chọn ảnh bên phải của thẻ 2-up và kéo để bạn có thể nhìn thấy những 

điểm sau đây: Bóng râm của cây dương, một số cây ở thung lũng đá và đỉnh núi với màu xanh da trời 

nhạt bên phải của nó.  

  

 

 

4. Trong tuỳ chọn Colors trong bảng Optimize, gõ hoặc chọn số 32 trong menu pop-up.  

 
 

Chú ý độ giảm đáng kể của kích cở tập tin nhưng có 3 vấn đề. Bóng giữa những hàng cây dương bây 

giờ là màu nâu sậm thay vì là màu xanh lá cây sậm, trong khi những cây ở hình thung lũng là màu 

xanh lá cây sậm thay vì màu nâu. Những đám mây trên bầu trời thung lũng màu nâu có sọc rõ rệt trong 

đa sắc màu.  
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5. Chọn lại trị số 128 trong tuỳ chọn Colors Một cách hiển nhiên, chỉ đơn thuần giảm bảng màu thì 

không giải quyết được vấn đề này. Đây không phải là ý kiến hay. Tuy nhiên, có một số kỹ thuật mà bạn 

sẽ thử sắp tới đây sẽ cho những kết quả khả quan hơn. 

 

Tăng độ hoà sắc để tạo giả những màu bị thiếu 

Trước khi bắt đầu phương thức này, bảo đảm là bảng Optimize vẫn còn thể hiện tuỳ chọn Perceptual 

as the Reduction và 

trị số 128 đối với Colors. Trong hình thung lũng, Chú ý dãy màu nâu kiểu gradient trong những đám 

mây. Bạn sẽ tập trung vào phần này của ảnh và bóng cây dương khi bạn chỉnh sửa trong chủ đề này. 

 

1. Bên dưới mục Dither trong bảng Optimize, chọn Diffuse trong menu pop-up Method và kéo con trượt 

đến 100%.  

 
 

Bây giờ một mẫu đốm làm dịu sự chuyển tiếp màu sắc và vùng mây. Bất kỳ sự thay đổi nào trong vùng 

cây dương đều không đáng chú ý 

2. Chọn lại trị số 32 trong tuỳ chọn Colors.  
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Hình cây dương trông có vẻ thậm chí còn tệ hơn trước đây. Vùng này có màu xanh lá cây sậm giờ đây 

xuất hiện những đốm nâu sậm trên màu xanh lá cây vừa. Những đám mây trong vùng thung lũng trông 

phẳng hơn nhưng bầu trời trên thung lũng và những ảnh núi - cả hai trước đây đều là những màu 

thuần nhất thì bây giờ có đốm. 

 

3. Kéo con trượt Dither xuống 50% và thử với những tỉ lệ khác.  

ImageReady giảm thiểu tối đa độ hoà sắc trong ảnh này nhưng không có tỉ lệ hoà sắc nào sẽ giữ 

những bóng đổ mà không làm tổn hại đến nền xanh lá cây. Cũng vậy, giảm tỉ lệ độ hoà sắc sẽ tạo ra 

những sọc đa sắc trong những đám mây bên trên thung lũng. 

4. Chọn lại Dither tới 100%  

5. Chọn lại tuỳ chọn Colors là 128. (Giữ nguyên những thiết lập của Dither.) 

 

Bóng cây dương một lần nữa lại biến thành màu xanh lá cây sậm và các đốm thì không hiện rõ. Trong 

khi kích thước tập tin nhỏ hơn ảnh gốc chưa được tối ưu hoá, ảnh được tối ưu hoá hơi lớn hơn một 

chút mà không có hoà sắc. Bạn còn nhiều việc phải làm để tối ưu hoá tập tin này, hãy sang chủ đề kế 

tiếp.  

 

Phần minh hoạ hiệu ứng tỉ lệ độ hoà sắc khác nhau trên một ảnh, xem hình 16-2 trong phần màu sắc.  

 

Khoá các màu để giữ lại các chi tiết của hình ảnh  

Trong các phương thức trước đây, bạn thấy cách giảm số lượng màu có thể làm mất một số chi tiết 

trong ảnh, thậm chí sau khi bạn tăng độ hoà sắc. Bây giờ bạn sẽ học cách khoá những màu đặc biệt 

để đảm bảo những màu này không bị giảm trong bảng màu. 

Khi bắt đầu thao tác này, đảm bảo bảng Optimize thể hiện Perceptual, 128 màu và thiết lập độ hoà sắc 

là 100%. 

 

1. Trong hộp công cụ, chọn công cụEyedropper và bấm chọn màu xanh lá cây sậm nhất. Bạn sẽ thấy 

trong bóng cây dương lấy mẫu màu đó.  

Chú ý là hiện giờ màu xanh lá cây sậm xuất hiện trong bảng Foreground Color swatch trong hộp công 

cụ và mẫu màu li ti đối với màu xanh lá cây sậm trong Color Table sáng lên với đường biên màu trắng. 
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2. Bấm biểu tượng hình chiếc khoá  ở cuối bảng Color Table để khoá màu xanh lá cây được chọn. 

Khoá một mẫu màu dành ưu tiên cho những màu không bị khoá. Nếu bạn giảm đi số lượng màu từ 

128 xuống trị số thấp hơn, những màu bị khoá không đụng với danh sách những màu không bị khoá.  

 

3. Trong bảng Optimize, trả giá trị Colors về trị số 32 

Bây giờ bóng màu xanh lá cây trông đẹp mắt nhưng hãy Chú ý sự hoà sắc có đốm này đã đi vào trong 

vùng bầu trời trong thung lũng màu nâu và những vùng núi màu xanh của ảnh, bắt đầu trông giống như 

một cơn bão tuyết. Một lần nữa, những cây trong thung lũng lẽ ra là màu nâu thì lại là màu xanh lá cây 

sậm. Dù vậy bạn nên tiếp tục cố gắng.  

 

4. Nhấn giữ thanh spacebar để con trỏ thay đổi từ biểu tượng công cụ Eyedropper thành biểu tượng 

bàn tay . Kéo tấm ảnh để phân nữa ảnh bị che bởi ảnh thung lũng và phân nữa ảnh bị che bởi ảnh 

núi.  

 
 

5. Trong palette Optimize, chọn trị số 128 trong tuỳ chọn Colors.  

Tiếp tục sang chủ đề kế tiếp, bạn sẽ khoá được nhiều màu hơn cho đến khi ảnh có được kết quả chấp 

nhận được.  
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Chú ý: Bạn có thể mở một màu đã bị khoá bằng cách chọn mẫu màu trong Color Table và bấm nút 

Lock một lần nữa. 

  

Khoá nhiều màu để ngăn chận độ hoà sắc không mong muốn  

Một thách thức khi làm việc với 32 màu là tìm được 32 màu lý tưởng. Như bạn đã thấy trong phương 

thức trước đây, chỉnh sửa một hiệu ứng hoà sắc không mong muốn hoặc dịch chuyển màu trong một 

vùng có thể phát sinh một số vấn đề trong một số vùng nào đó.  

Thà là bỏ đi quá trình khoá màu, bạn sẽ tiếp tục chỉnh lại hình ảnh bằng cách khoá nhiều màu. Bạn sẽ 

chọn lựa nhiều lần giữa 32 màu và 128 màu. Khoá màu gốc khi giảm xuống 32 màu sẽ gây ra độ hoà 

sắc không mong muốn hoặc có sự thay đổi màu sắc. Bạn khoá một màu một lần nữa, điều quan trọng 

là xem lại cả tấm ảnh một cách thận trọng để xem việc khoá màu đã đưa đến những hệ luỵ nào.  

 

1. Chọn công cụ Eyedropper và bấm chọn màu nâu sậm hiện giờ đang nằm chính giữa những cây 

trong ảnh thung lũng. Bấm nút Lock ở dưới đáy bảng Color Table để khoá màu được chọn.  

  

 
 

Một hình vuông nhỏ xuất hiện trong thẻ swatch cho thấy màu này đã bị khoá.  

2. Lập lại bước 1 thêm 3 lần nữa, lấy mẫu và khoá các phần sau đây: 

• Vùng trời màu nâu vừa trong vùng thung lũng. 

• Vùng trời nâu sậm góc trên trái của đỉnh núi. 

• Vùng trời xanh nhạt bên phải đỉnh núi. 
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3. Giảm tuỳ chọn Colors xuống trị số 32. 

 

4. Nhấn giữ thanh spacebar để con trỏ biến thành biểu tượng bàn tay và kéo ảnh để bạn có thể thấy 

bìa rừng phía trước núi, phần số 4 và văn bản ở góc dưới phải của ảnh. Bây giờ chóp đỉnh trong ảnh 

màu xanh bị hoà sắc không thể chấp nhận được. 

 

5. Thay đổi số lượng màu về trị số 128 và sử dụng cùng một kỹ thuật mà bạn áp dụng ở bước 1 và 2 

để khoá màu xanh sậm ở phần chóp đỉnh rồi trở lại tuỳ chọn Colors chọn trị số 32.  

 

Phần chóp đỉnh trông rất đẹp nhưng giờ đây phần văn bản màu khaki bị hoà sắc đến độ nó trông giống 

như hoa giấy sặc sỡ. Cố lên; bạn sắp đạt tới mục tiêu rồi đó. 

6. Trả số lượng màu về trị số 128 và dùng kỹ thuật mà bạn đã sử dụng ở bước 1 và bước 2 để khoá 

màu. Trong tuỳ chọn Colors, chọn trị số 32.  

 

7. Khảo sát từng vùng của ảnh để đảm bảo rằng không có sự dịch chuyển nào của màu sắc rồi chọn 

File > Close.  

 

Nếu bạn muốn làm như thế, bạn có thể tiếp tục khoá các màu, chẳng hạn như màu sậm hơn ngay 

chính giữa cây cau dừa hoặc một số màu khác. 

 

Chú ý: Có sự hoà sắc không thể tránh khỏi được chẳng hạn như những vùng được tô màu ở chế độ 

gradient. Mỗi một trong 4 khối ảnh màu có chế độ gradient tách nền màu đặc khỏi ảnh mà nó chứa. 

Hoà sắc là chọn lựa tốt nhất để hài hoà hiệu quả của ảnh và ngoại hình của ảnh đối với những thay đổi 

màu gradient. 

 

Nếu bạn thử nghiệm với việc tối ưu hoá các tập tin ảnh, bạn sẽ thấy rằng độ nhạt màu của ảnh có thể 

xảy ra khi bảng màu bị giảm dưới 32 màu. Thật vậy, hầu như những tấm ảnh đơn giản nhất, thậm chỉ 

32 màu, cũng có thể bị giảm sút đáng kể. Đối với việc nén một tập tin ảnh dạng GIF, cố gắng dùng số 

lượng màu ít nhất để thể hiện chất lượng mà bạn cần. 
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Phần minh họa ảnh ở những giá trị của palette khác nhau, xem hình 16-1 ở phần màu.  

 

Giảm thiểu độ hoà sắc trình duyệt  
Trong Photoshop, hộp thoại Save For Web và trong ImageReady, bạn có thể xem hoà sắc ứng dụng 

trực tiếp trong ảnh đã được tối ưu hoá. Bạn cũng có thể xem trước hoà sắc trình duyệt phụ xuất hiện 

trong ảnh cuối cùng khi xem trong 1 trình duyệt sử dụng chế độ xem 8 bit.  

Như bạn đã biết trước đây, những ảnh bao gồm các màu không an toàn web phải trải qua quá trình 

hoà sắc khi thể hiện trong 1 trình duyệt web ở chế độ 8 bit vì trình duyệt mô phỏng màu không xảy ra 

trong bảng hệ thống 8 bit. Từ ImageReady, bạn có thể xem trước cách một ảnh được tối ưu hoá sẽ 

như thế nào khi được hoà sắc trong 1 trình duyệt Web.  

Để bảo vệ một màu không bị hoà sắc trong trình duyệt, bạn có thể dịch chuyển web màu đó, đổi màu 

đó ra một giá trị tương đương gần nhất trong bảng Web. Ví dụ bảng Web bao gồm những mảng màu 

phụ xuất hiện trong cả bảng hệ thống Window và Mac OS. Các màu trong bảng Web thể hiện mà 

không hoà sắc trong các trình duyệt trên bất cứ nền nào. 

 

1. Với tập tin ảnh 16Start2.psd được mở ra, chọn View > Preview > Browser Dither ( để dấu kiểm xuất 

hiện bên cạnh dòng lệnh.) Chú ý rằng hoà sắc trình duyệt xảy ra trên bầu trời và dốc của ảnh thung 

lũng cho dù bạn đã khoá màu nâu vừa của bầu trời trước đây trong bài học này. Bạn sẽ dịch chuyển 

web màu đó để giảm độ hoà sắc trình duyệtn trong ảnh này.  

 

Chú ý: Nếu bạn không thấy độ hoà sắc, tăng độ phóng lớn hoặc tắt phần xem trước hoà sắc trình 

duyệt rồi trở về để quan sát hiệu ứng. Bạn có thể bật/tắt phần xem trước hoà sắc trình duyệt bằng cách 

nhấn phím Ctrl+Shift+Y (Windows) hoặc Command+Shift+Y (Mac OS) 

 

2. Thoát ra khỏi chế độ xem trước trình duyệt nhưng lần này nhấn nút Ctrl+Shift+Y (Window) hoặc 

Command+Shift+Y (Mac OS) hoặc bạn có thể dùng lệnh View > Preview > Browser Dither một lần nữa. 

 

3. Chọn công cụ Eyedropper và bấm vào bất kỳ nơi nào trên vùng bầu trời thung lũng. Màu mẫu được 

chọn trong bảng Color Table.  
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4. Bấm nút Web-shift ở đáy bảng Color Table.  

 
 

Mẫu màu đổi vị trí trong bảng và một viên kim cương nhỏ xuất hiện chính giữa mẫu màu cho thấy rằng 

nó đã được dịch chuyển sang màu tương đương gần nhất của Web.  

 

5. Sử dụng cùng một kỹ thuật, chọn một mẫu màu nâu nhạt hơn trên dốc của thung lũng và bấm 

nútWeb-shift một lần nữa.  

 

6. Chọn View > Preview > Browser Dither, hoặc nhấn Ctrl+Shift+Y (Window) hoặc 

Command+Shift+Y(Mac OS) để xem trước tập tin trong chế độ này. 

Hoà sắc trình duyệt mất đi khỏi những vùng được chọn và phần còn lại của ảnh là có thể chấp nhận 

được. 

 

7. Chọn View > Preview > Browser Dither để bỏ chọn nó rồi chọn File > Save. 

 

Bằng cách dịch chuyển web nền màu nâu, bạn đổi màu của nó thành một màu có thể hiển thị mà 

không bị hoà sắc bởi trình duyệt Web trên hệ thống 256 màu. 

 

Chú ý: Trong Photoshop CS và ImageReady CS bạn có thể chuyển đổi nhanh một màu sang màu 

khác hoặc sang độ trông suốt.Việc chuyển đổi này gán lại tất cả những điểm ảnh xuất hiện ở màu chọn 

thành màu mới hoặc trông suốt. Để biết thêm thông tin, xem phần trợ giúp của ImageReady.  
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Tối ưu hoá các Slice 

Các nhà thiết kế chuyên nghiệp thường kết hợp các loại nguồn ảnh khác nhau thành một ảnh đơn 

thuần trong Photoshop hoặc ImageReady. Thí dụ, bạn có thể tạo một tập tin ảnh gồm những ảnh có 

những vùng màu nhạt và kiểu in kết hợp với những ảnh có tông màu liên tục hoặc những ảnh khác ở 

chế độ tô màu theo tỉ lệ và bóng phức tạp. Rất khó đạt được những kết quả thoả đáng khi tối ưu hoá 

những ảnh như thế nếu chỉ sử dụng đơn thuần một phương án tối ưu hoá. 

 

Nếu bạn chia ảnh thành từng slice, bạn có thể tối ưu hoá từng slice rời biệt lập. Thí dụ, bạn có thể ứng 

dụng việc tối ưu hoá dạng GIF cho một số vùng trong 1 ảnh trong khi đó ứng dụng việc tối ưu hoá dạng 

JPEG hoặc PNG cho các ảnh khác. Để làm điều này, bạn chỉ việc chọn một slice riêng (dùng công cụ 

chọn slice) và thiết lập tuỳ chọn tối ưu hoá trong hộp thoại Save For Web (Photoshop) hoặc bảng 

Optimize (ImageReady). 

 

Xác định độ trong suốt của phần nền 

Bạn có thể sử dụng độ trong suốt của phần nền để đặt một đối tượng đồ họa không phải là hình chữ 

nhật lên nền của trang Web; những vùng ngoài biên của đối tượng được xác định là trong suốt, để 

màu nền của trang Web thể hiện xuyên suốt. Bạn có thể xác định độ trong suốt của phần nền đối với 

các ảnh dạng GIF và PNG. 

 

Chuyển đổi lớp nền (Background) thành lớp bình thường 

Trước khi bạn sử dụng khả năng của tập tin dạng GIF để giữ lại độ trong suốt, bạn phải tạo độ trong 

suốt trong ảnh của bạn. Bạn sẽ làm điều đó bằng cách dời đi phông màu trắng xung quanh ảnh. Để bắt 

đầu tiến trình này, đầu tiên bạn sẽ chuyển đổi lớp Background thành lớp bình thường vì lớp 

Background luôn luôn bị khoá và không thể có độ trong suốt.  

 

1. Đảm bảo rằng tập tin 16Start2.psd đang được mở trong ImageReady. 

 

2. Chọn ảnh gốc bên trái của cửa sổ ảnh. 

 

3. Chọn Fit on Screen từ menu Zoom Level ở góc phía trái bên dưới của cửa sổ ảnh. 

 

4. Chọn Window > Layer để mở bảng Layers rồi mở menu của bảng layers và chọn Layers Options.  
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5. Bấm OK để đóng hộp thoại Layer Options mà không thay đổi những thiết lập mặc định ( kể cả tên 

Layer 0). Lớp này giờ đây xuất hiện trong bảng Layer là Layer 0. 

 

 
 

Layer Background không thể chứa bất cứ thông tin nào về độ trông suốt vì theo định nghĩa, không có 

gì phía sau nó được nhìn thấy. Nếu bạn cố gắng dùng một trong những kỹ thuật thường có thể thay 

thế các điểm ảnh màu bằng những điểm ảnh trông suốt, kết quả sẽ là các điểm ảnh gốc sẽ được 

chuyển thành màu nền được chọn hiện hành thay vì trở thành những điểm ảnh trông suốt.  

 

Sử dụng công cụ Magic Eraser để tạo độ trông suốt 
Trong phần này của bài học bạn sẽ sử dụng công cụ Magic Eraser để chuyển đổi nhanh nền màu trắng 

phía sau các ảnh và chữ viết thành các điểm ảnh trông suốt. 

Tuy nhiên, bạn không muốn xoá bất kỳ điểm ảnh màu trắng nào có thể xuất hiện bên trong những tấm 

ảnh màu. Bạn sẽ hoàn tất điều này qua 2 bước.  

 

1. Đảm bảo rằng ảnh gốc bên trái của cửa sổ ảnh được chọn. Bạn có thể xoá những điểm ảnh nền chỉ 

trong ảnh chưa được tối ưu hoá, chứ không phải trong ảnh đã được tối ưu hoá. 

 

2. Chọn công cụ Magic Eraser là công cụ ẩn nằm dưới công cụ Eraser. 
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3. Trong thanh tuỳ chọn công cụ, đảm bảo rằng hộp kiểm Contiguous đang được chọn. 

 

4. Bấm vào nền trắng xung quanh những ảnh màu.  

 
 

Mẫu checkerboard thay thế nền trắng cho thấy rằng vùng này trong suốt 

 

5. Bấm chọn vùng màu trắng hình chữ nhật đang nằm chính giữa 4 khối màu.  

 
 

Giờ đây hầu hết phông nền màu trắng đã bị xoá ngoại trừ những hòn đảo nhỏ gồm những điểm ảnh 
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màu trắng trong vùng có chữ được khép kín. 

 

Chuyển đổi những vùng màu trắng bị cô lập thành trong suốt 
Công cụ Magic Eraser không xoá những vùng màu trắng bị cô lập trong vùng chữ vì tuỳ chọn 

Contiguous đang được chọn trong thanh tuỳ chọn công cụ. 

Một cách để chỉnh sửa điểm này là phóng to ra và bấm vào mỗi vùng màu trắng trong các chữ, giống y 

như bạn bấm vào hình chữ nhật màu trắng nằm giữa ảnh. 

Thay vì thế, bạn sẽ sử dụng một phương pháp hoạt động hữu hiệu hơn nhiều trong những trường hợp 

có một số lớn các vùng nhỏ nằm rải rác mà bạn muốn xoá trong khi muốn giữ lại những vùng có các 

điểm ảnh màu tương tự mà bạn không muốn xoá. 

 

1. Trong thanh tuỳ biến công cụ đối với công cụ Magic Eraser, bỏ tuỳ chọn Contiguous.  

  

 
 

2. Chọn công cụ Rectangular Marquee và cẩn thận vẽ một vùng chọn hình chữ nhật bao quanh chữ 

Corners trong ảnh gốc nằm bên trái.  

 
 

3. Bấm giữ phím Shift để con trỏ biến thành biểu tượng 1 dấu cộng nhỏ xuất hiện và kéo 1 vùng chọn 

khác hình chữ nhật quanh chữ “Travel” và chữ “of”. Hai vùng chọn trở thành một vùng. (Bạn có thể tạo 

vùng chọn riêng biệt cho chữ “of” nếu bạn thích giữ phím Shift và kéo để gia tăng vùng chọn. Hoặc bạn 

có thể thêm 1 khối màu vàng nhỏ khi bạn chọn chữ “Travel” và chữ “of”.)  
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4. Chọn công cụ Zoom và phóng lớn để bạn dễ nhìn thấy những vùng nằm trong vùng chọn (khoảng 

300%).  

 

5. Chọn công cụ Magic Eraser rồi cẩn thận bấm vào nền màu trắng trong chữ “O”.  

 
 

Các điểm ảnh màu trắng trong chữ “O” được chuyển đổi thành các điểm ảnh trong suốt, tương tự các 

điểm ảnh trong chữ “A” và “R” trong chữ “Travel” và chữ “O” trong chữ “of” cũng có tác dụng như vậy.  

 

6. Chọn Select > Deselect rồi chọn File > Save. 

 

Hoàn tất bảng Color Table 

Mặc dù người ta ít nghĩ độ trong suốt là một màu, nó không được xem như 1 trong 32 màu trong bảng 

màu đối với hình ảnh.Điều này có nghĩa là bạn cần lại hình ảnh một lần nữa để tìm ra bất kỳ độ hoà 

sắc nào không thể chấp nhận được gây ra do sự chuyển dịch sang độ trong suốt. 

 

1. Cuộn hoặc chọn công cụ bàn tay và kéo để xem xét tất cả các vùng của ảnh.  

 

Chú ý hiện giờ có độ hoà sắc nặng trong vùng màu xanh xung quanh cây dương. 
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2. Chọn ảnh đã được tối ưu hoá nằm bên phải cửa sổ ảnh. 

 

3. Trong tuỳ chọn Color của palette Optimize, chọn trị số 128. 

 

4. Chọn công cụ Eyedropper và bấm chọn vùng màu xanh vừa góc trên bên phải của ảnh cây dương.  

 
 

5. Trong bảng Color Table, bấm vào biểu tượng ổ khoá để khoá màu.  

 
 

6. Trong palette Optimize, chọn trị số 32 là số lượng màu. 

 

7. Cuộn hoặc sử dụng công cụ bàn tay để xem hình một lần nữa, xác định rằng ảnh đã có sự cân bằng 

hài hoà giữa độ hoà sắc và kích thước tập tin. Chọn File > Close. 

 

Xem trước độ trong suốt 
Bây giờ bạn sẽ xem trước độ trong suốt trong trình duyệt của bạn. Vì đặc điểm xem trước trong 

ImageReady thể hịên hình ảnh này trên trang web với nền trắng, bạn sẽ thay đổi màu của ảnh để có 

thể thấy độ trong suốt. 

 

1. Trong cửa sổ ảnh, chọn ảnh đã được tối ưu hoá (nằm bên phải)  

 

2. Trong bảng Optimize, đảm bảo hộp kiểm Transparency được chọn.  
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Chọn Transparency chuyển đổi những vùng trong ảnh gốc với độ mờ đục nhỏ hơn 50% sang độ mờ 

đục nền trong ảnh đã được tối ưu hoá. 

 

3. Chọn mẫu Matte trong palette Optimize để mở color picker rồi chọn bất kỳ màu gì trừ màu trắng. 

Bấm OK để đóng color picker.  

 
 

4. Chọn File > Preview In và chọn trình duyệt web từ menu con  

Chú ý: Để sử dụng lệnh Preview In, bạn phải có một trình duyệt Web cài trên hệ thống của bạn. 

 

Nếu ảnh chưa mở ra, trình duyệt đầu tiên bắt đầu rồi hiện ảnh đã được tối ưu hoá ở góc trên trái của 

cửa sổ trình duyệt. Trình duyệt này cũng cho biết kích thước điểm ảnh, kích thước tập tin, dạng tập tin 

và các thiết lập tối ưu hoá cho ảnh cùng với mã HTML được dùng để tạo ra phần xem trước.  
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5. Thoát khỏi trình duyệt khi bạn kết thúc phần xem trước ảnh. 

 

Xén vùng nền thừa 

Dù phần nền của ảnh tổ chức du lịch giả tưởng hiện giờ có chứa các điểm ảnh trông suốt nhưng không 

thể hiện, những điểm ảnh này vẫn còn chiếm không gian tập tin, tăng thêm kích thước của ảnh. Bạn có 

thể xén đi phần vùng nền không cần thiết để cải thiện bố cục của ảnh và tối ưu hoá kích thước tập tin. 

 

1. Trong ImageReady, chọn Image > Trim.  

Bạn sử dụng lệnh Trim để xén ảnh theo độ trông suốt hoặc màu điểm ảnh của vùng biên thừa. 

 

2. Trong hộp thoại Trim, chọn các điểm ảnh trông suốt nếu chưa được chọn và bấm OK.  
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ImageReady xén vùng trông suốt thừa ra khỏi ảnh. 

 

3. Chọn File > Save Optimized As. 

 

4. Trong hộp thoại Save Optimized As, dùng tên mặc định (16Start2.gif) và bấm chọn Save. 

 

5. Trong hộp thoại Replace Files, bấm Replace (nếu nó xuất hiện) 

 

6. Chọn File > Close.  

 

7. Bạn sẽ được nhắc để lưu tập tin  

 

16.Start2.psd trước khi đóng nó lại. Đối với bài học này bạn đã kết thúc với tập tin này nên không cần 

lưu những thay đổi cuối cùng. 

 

Tạo sự trong suốt hoà sắc 

Trong phần này của bài học 16, bạn sẽ tạo một độ trong suốt hoà sắc cho 1 ảnh đồ hoạ được dùng 

trong 1 vùng khác của Web site cho tổ chức du lịch giả tưởng. Bằng cách tạo một độ hoà sắc từ bóng 

đổ mờ đục thành trông suốt, bạn sẽ có thể tạo ra một sự chuyển dịch uyển chuyển từ ảnh này sang 

phông nền thuộc bất kỳ màu nào trên trang mà không phải làm lại bất cứ việc gì. 

 

Bạn sẽ làm điều này trong 2 thủ tục. Đầu tiên bạn sẽ áp dụng một hiệu ứng bóng đổ vào ảnh. Tiếp đến 

bạn sẽ thêm độ hoà sắc vào bóng đổ để nó pha trộn thành màu nền cho trang Web. Bạn có thể làm 

điều này trong Photoshop và ImageReady, sử dụng các phương pháp điều khiển giống nhau trong 

những vị trí hơi khác một chút. 

 

Thêm 1 bóng đổ 

Tập tin bạn sẽ làm việc có tác dụng như một ảnh mà những người sử dụng bấm vào để mở trên 1 
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trang khác của Web site. Bạn sẽ thêm 1 bóng đổ vào nút này để làm cho ảnh nổi lên trên phần nền, 

nhấn mạnh rằng nó là thành phần tương tác của trang này. 

 

1. Chọn File > Open rồi chọn tập tin 16Start3.psd trong thư mục Lesson16 của thư mục Lesson. 

 

2. Nếu cần, chọn Window > Layers để mở bảng Layers rồi chọn layer1 nếu nó chưa được chọn. 

 

3. Chọn nút Add A Layer Style ở cuối bảng layers rồi chọn Drop Shadow từ menu. 

 

4. Trong hộp thoại Layer Style, nhập vào các giá trị như sau: 

• Đối với mục Opacity kéo con trượt hoặc gõ vào giá trị 65%. 

• Đối với mục Distance, kéo con trượt hoặc gõ vào trị số15px. 

• Đối với mục Spread, kéo con trượt hoặc gõ vào trị số 10%. 

• Đối với Size, kéo con trượt hoặc gõ vào trị số 15px. 

5. Bấm chọn OK để đóng hộp thoại Drop Shadow.  

 
 

6. Chọn File > Save. 

 

Thêm độ hoà sắc trong suốt vào bóng đổ  

Như bạn đã biết, hoà sắc chính là 1 phương pháp tạo sự chuyển tiếp màu trong bảng màu giới hạn. 

Điều này hữu ích đối với các trang Web vì bạn có thể bắt chước sự giảm màu liền lạc hơn mà không 

làm ảnh hưởng đến kích cở tập tin và tải xuống nhanh. 

 

1. (Chỉ áp dụng trong Photoshop) Với tập tin 16Start3.psd đang mở, chọn File > Save For Web để mở 

hộp thoại Save For Web. Bước này không cần thiết trong ImageReady.  
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2. Bấm thẻ Optimized trong hộp thoại Save For Web (Photoshop) hoặc cửa sổ ảnh (ImageReady) rồi 

thiết lập các tuỳ chọn sau đây bên phải hộp thoại Save For Web (Photoshop) hoặc bảng Optimize 

(ImgeReady): 

• Trong menu Preset, chọn GIF 128 Dithered. 

• Chọn hộp kiểm Transparency nếu hộp này chưa được chọn. 

• Trong menu Dither dành cho Transparency, chọn Diffusion. 

• Trong tuỳ chọn Amount, dùng con trượt hoặc nhập trị số 64%.  

 
 

3. Bấm Matte swatch để mở hộp Color Picker. Chọn bất kỳ màu nào khác màu trắng và bấm OK. 

(Chúng tôi chọn R=250, G=234, B=212), màu nâu nhạt làm nổi bật những màu xanh trong ảnh hộp thư. 

Để thấy được hiệu ứng của thiết lập lưới (matte), cố gắng phóng lớn khoảng 400% và thậm chí tới 

1600% là tối đa để bạn nhìn thấy các điểm ảnh riêng rẻ trong độ hoà sắc. Chú ý rằng các điểm ảnh 

nằm sát rìa của hộp thư và vùng khung màu xanh là màu sậm,và những màu khác gia tăng độ hoà trộn 

với màu matte ở vị trí nằm xa rìa. Thu nhỏ lại còn 100%.  
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4. Làm 1 trong các việc sau:  

• (Trong Photoshop) Ở đáy hộp thoại Save For Web, bấm vào nút có biểu tượng trình duyệt 

hoặc bấm mũi tên để chọn trình duyệt từ menu. 

• (Trong ImageReady) Sử dụng nút Preview In Default Browser hoặc menu con Preview In trên 

menu File để mở tập tin trong 1 trình duyệt. 

5. Trong trình duyệt, Chú ý cách bóng đổ được hoà trộn vào màu matte nền. Khi xem xong tài liệu, 

đóng trình duyệt hoặc trở về Photoshop hay ImageReady  

  

 

 

6. Bấm nút Save trong hộp thoại Save For Web (Photoshop) hoặc chọn File > Save Optimized 

(ImageReady). 

 

7. Trong hộp thoại Save Optimized, chấp nhận các thiết lập mặc định và tên của tập tin (16Start3.gif) 
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và lưu tập tin trong Lessons/Lesson16 folder.  

 

8. Chọn File > Save để lưu tập tin 16Start3.psd hoặc đóng tập tin lại không cần lưu. 

 

Tối ưu hoá tập việc xử lý hàng loạt tập tin 

ImageReady hỗ trợ việc xử lý hàng loạt qua việc sử dụng Droplets - biểu tượng chứa những hoạt động 

dành cho ImageReady để thực hiện trên 1 hoặc nhiều tập tin. Droplets dễ tạo và dễ sử dụng. Để tạo 

một droplet, bạn kéo biểu tượng droplet ra khỏi bảng Optimize vào trong desktop. Để sử dụng nó, bạn 

kéo 1 tập tin hoặc 1 thư mục qua biểu tượng droplet trên desktop.  

 

1. Trong ImageReady, chọn File > Open, mở bất kỳ tập tin nào trong thư mục đích Lessons/Lessons16. 

 

2. Thử nghiệm với các dạng tập tin khác nhau và các thiết lập khác trong bảng Optimize như bạn muốn 

cho đến khi bạn hài lòng với kết quả. (Chúng tôi sử dụng định dạng , JPEG, High cho chất lượng và tuỳ 

chọn Progressive.) 

 

3. Kéo biểu tượng Droplet ra khỏi bảng Optimize và đặt bất cứ nơi nào trên Desktop. (Nếu bạn đang 

sử dụng Window, có thể bạn phải lấy lại kích thước cửa sổ ImageReady để thấy được desktop.)  

 
 

4. Đóng tập tin lại (không lưu) 

 

5. Từ Desktop kéo thư mục đích từ thư mục Lesson16 trong thư mục Lessons và thả nó vào droplet để 

xử lý hàng loạt các ảnh đồ hoạ trong thư mục.  

ImageReady tối ưu hoá mỗi ảnh và thêm ảnh Web vào thư mục đích. 
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6. Trong ImageReady, mở bất kỳ hoặc tất cả các tập tin có định dạng JPEG trong thư mục đích. 

 

Chú ý là tất cả đều được tối ưu hoá theo các thiết lập đã xác định khi droplet được tạo ra. 

 

7. Thoát ImageReady. Bây giờ bạn đã kết thúc chương trình và bài học này.  
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Các câu hỏi ôn tập 

1. Đối với việc tối ưu hoá hình ảnh, đâu là những ưu điểm của việc sử dụng ImageReady so với 

Photoshop? 

 

2. Color Table là gì? 

 

3. Khi nào thì hoà sắc trình duyệt xảy ra và làm thế nào bạn có thể giảm thiểu số hoà sắc trình duyệt 

trong 1 ảnh? 

 

4. Mục đích của việc gán matte color cho ảnh GIF là gì? 

 

Các câu trả lời ôn tập 

1. Thật sự có nhiều lợi điểm khi sử dụng một trình ứng dụng này đối với trình ứng dụng khác trong việc 

tối ưu hoá.Cả Photoshop lẫn ImageReady đều có thể thực hiện được một phạm vi rộng rãi những thao 

tác nhằm tối ưu hoá ảnh. ImageReady có nhiều đặc điểm chuyên Web mà bạn sẽ không tìm thấy trong 

Photoshop, nhưng tối ưu hoá hình ảnh không phải là một trong những đặc điểm này. 

 

2. Color Table là một bảng chứa các màu sử dụng ảnh 8 bit. Bạn có thể chọn 1 color table cho ảnh GIF 

và PNG-8, thêm, bớt và chỉnh sửa màu trong Color table.  

 

3. Hoà sắc trình duyệt xảy ra khi một trình duyệt Web nhái những màu xuất hiện trong bảng màu của 

ảnh nhưng không xuất hiện trong hệ thống hiển thị của trình duyệt. 

Để bảo vệ một màu khỏi hoà sắc trình duyệt, bạn có thể chọn màu trong bảng Color Table rồi bấm 

chọn nút Web-shift ở cuối bảng để dịch chuyển màu sang màu 

tương đương gần nhất của nó trong bảng Web. 

 

4. Qua việc xác định một lưới màu (matte color), bạn có thể pha trộn phần nào các điểm ảnh trong suốt 

trong 1 ảnh với màu nền trong trang Web của bạn. Với lưới (matting), bạn có thể tạo những ảnh GIF 

với rìa mềm mại không có răng cưa hoà sắc nhẹ nhàng vào màu nền của trang Web. Bạn cũng có thể 

xác định độ hoà sắc 

thành trong suốt. 
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